N-central Help

KBA20021: Upgrading Linux Agents from 9.5.x to 10.x

Knowledge Base Article #: 20021
Applicable Versions: SolarWinds N-central 9.5.x, 10.x
Date Created/Updated: April 21, 2015

Introduction

Upgrading Linux Agents from 9.5.x to 10.x may fail due to the Agent software using SSL v3. The error message: 'Agent upgrade failed. Invalid upgrade parameters.' may be reported.

Troubleshooting

To resolve this issue, you will need to modify the wget command line in the nagent_download.sh files by performing one of the following procedures: